1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Install virtual box on Kali 4.3.0

Discussion in 'Beginners Section' started by Mongrel, Jan 20, 2017.

  1. Mongrel

    Mongrel New Member

    Joined:
    Jan 20, 2017
    Messages:
    1
    Likes Received:
    0
    Hi everybody!

    I'm totally new here. Nice to meet you buds he.
    I'm running kali on a laptop samsung NP-Q45 (no clue if this matters, but better write it than not). So here's the point: if I try to install Vbox following what is said here: https://www.virtualbox.org/wiki/Linux_Downloads it doesen't really works. I mean, I, can't make it work. Honestly I don't even understand the 50% of what I'm doing. Once downloaded the .deb file for Debian 9 AMD64 (for example, is that right or should I download something else? I tried with Jesse as well but nope), I then add the line on /etc/apt/source.list and after that

    combine downloading and registering:
    wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
    OK
    wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -
    OK

    then I also

    apt-get install dkms

    and it's fine. But then everytime I try to

    apt-get install virtualbox

    I get this output:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    gsettings-desktop-schemas : Breaks: mutter (< 3.19.92) but 3.18.2-1 is to be installed
    libgnome-desktop-3-12 : Breaks: mutter (< 3.21.2) but 3.18.2-1 is to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    and this is the point where I say apt-get install help_what_the_fuckisgoingon

    I tried to install virtualbox-4.3 rather than 5.0 or 5.1 but the outputs are mostly the same.
    Tried to dpkg -i virtualbox___.deb file:

    Selecting previously unselected package virtualbox-5.1.
    (Reading database ... 311201 files and directories currently installed.)
    Preparing to unpack virtualbox-5.1_5.1.14-112924~Debian~stretch_amd64.deb ...
    Unpacking virtualbox-5.1 (5.1.14-112924~Debian~stretch) ...
    dpkg: dependency problems prevent configuration of virtualbox-5.1:
    virtualbox-5.1 depends on libpng16-16 (>= 1.6.2-1); however:
    Package libpng16-16 is not installed.
    virtualbox-5.1 depends on libqt5core5a (>= 5.7.0); however:
    Version of libqt5core5a:amd64 on system is 5.5.1+dfsg-12.
    virtualbox-5.1 depends on libqt5widgets5 (>= 5.7.0); however:
    Version of libqt5widgets5:amd64 on system is 5.5.1+dfsg-12.
    virtualbox-5.1 depends on libqt5x11extras5 (>= 5.6.0); however:
    Version of libqt5x11extras5:amd64 on system is 5.5.1-3.
    virtualbox-5.1 depends on libvpx4 (>= 1.6.0); however:
    Package libvpx4 is not installed.

    dpkg: error processing package virtualbox-5.1 (--install):
    dependency problems - leaving unconfigured
    Processing triggers for systemd (228-4) ...
    Processing triggers for gnome-menus (3.13.3-6) ...
    Processing triggers for desktop-file-utils (0.22-1) ...
    Processing triggers for mime-support (3.59) ...
    Processing triggers for hicolor-icon-theme (0.13-1) ...
    Processing triggers for shared-mime-info (1.5-2) ...
    Errors were encountered while processing:
    virtualbox-5.1

    Help please :D
     
    #1
  2. bokepid

    bokepid Member

    Joined:
    Mar 14, 2018
    Messages:
    47
    Likes Received:
    0
    terima kasih untuk posting
     
    #2

Share This Page