1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2016.2 installed but hanging early during startup

Discussion in 'Beginners Section' started by Hunter23, Dec 1, 2016.

  1. Hunter23

    Hunter23 New Member

    Joined:
    Dec 1, 2016
    Messages:
    1
    Likes Received:
    0
    Hi Everybody,

    Joined the forum today to get advice on an issue with completing the install of KL2016.2 on a Dell Inspiron laptop with Windows 10 in dual boot. I was surprised at the large number of messages posted about installation issues with KL so seems as though I a not alone but I couldn't find any reference to my particular issue hence the query. First off I am a relative Linux newbie - familiar with it to a point but have spent most of my years in Windows (sorry!).

    I started this journey a couple of days ago by attempting to put KL onto a bootable USB device using the standard guides provided on the KL forum. Seemed to work fine and laptop did boot to initial menu screen but when I selected live version it was always hanging and never completed loading. I tried using the same USB device on my desktop machine and it worked fine so assumed to be no issue with the USB and software on it.

    Today I figured I would try the dual boot option on the laptop. Went through the install procedure fine using the same USB to install KL from and I now have the option to boot KL or windows, with KL now occupying the MBR.
    When I launch the "Kali GNU/Linux" option from the "GNU GRUB Version 2.02~beta2-36" menu it stalls very early. All that I see on screen are the 3 lines below and from reading about these errors it didn't necessarily mean they were the showstoppers.

    /dev/sda7: clean, 320046/11763712 files, 2871457/47032064
    [ 7.285580] tpm_crb MSFT0101:00: can't request region for resource [mem 0xfed40040-0xfed4103f]
    [ 8.683628] lwlwifi 0000:02:00.0: Unsupported splx structure

    Could you KL Superheroes give me some troubleshooting tips as to where to start looking with this? I can get to a command line so can navigate and look at things but there isn't much to go on. How do I begin to evaluate where it's stalling?
    The fact that I could run the USB version on my desktop but not the laptop made me think it may be a video driver issue but no one else reporting similar with Intel and AMD Radeon R7 graphics, so it was just a guess.

    I booted KL into recovery mode and ran journalctl -xb to look for any obvious errors. Found a few strange entries related to failures in: -

    - fjes module verification failure,
    "fjes: module verification failed: signature and/or required key missing - tainting kernel"

    - tpm_crb failing with error -16
    "tpm_crb MSFT0101:00: can't request region for resource [mem 0xfed40040-0xfed4103f]
    tpm_crb: probe of MSFT0101:00 failed with error -16"

    - iwlwifi unsupported splx structure
    "iwlwifi 0000:02:00.0: Unsupported splx structure"

    - CRAT table not found

    - rescue.service failure with no such file or directory for /bin/Plymouth
    "rescue.service: Failed at step EXEC spawning /bin/Plymouth: no such file or directory"

    The rescue service error was the last entry.

    Thanks in advance for any help ! My laptop is pretty much useless until I get this fixed so will keep looking for solutions.
     
    #1

Share This Page